Skylark availability Issue detected in parts of North America (Pacific Northwest region, USA / Ontario, CAN / Newfoundland, CAN)

Incident Report for Skylark

Resolved

This incident has been resolved.
Posted May 29, 2025 - 05:09 UTC

Monitoring

Regional availability has been restored. Swift Navigation is monitoring the current status while continuing to investigate the root cause of the issue.
Posted May 29, 2025 - 01:29 UTC

Investigating

We are currently investigating this issue.
Posted May 29, 2025 - 01:22 UTC
This incident affected: Skylark Cx - North America.