Skylark localized availability issue in EU

Incident Report for Skylark

Resolved

A fix has been implemented to resolve the issue.
Posted Sep 14, 2025 - 21:01 UTC

Identified

The issue has been identified. A fix is currently being developed.
Posted Sep 14, 2025 - 20:04 UTC

Investigating

We are currently investigating this issue.
Posted Sep 14, 2025 - 19:56 UTC
This incident affected: Skylark Dx - Europe and Skylark Nx RTK - Europe.